This is the test/beta version of the archlinux32 forum.

You are not logged in.

#1 2018-03-13 16:30:25

goverp
Member
Registered: 2018-03-03
Posts: 3

Bug report: LXDM fails with invalid op-code in librsvg-2:2.42.1-1.0

I think this is an CPU support issue, with librsvg needing SSE or SSE2, and my Pentium III a bit short.

The symptom is LXDM fails to bring up its login screen, so I can only use the machine via the console.
dmesg and journalctl both show an error message from lxdm-greeter-gt

The message is
     lxdm-greeter-gt[427] trap invalid opcode ....

I restored librsvg-2:2.40.19-1 and that fixed the problem.

I would open it on bugs.archlinux32.org, where I'm a registered user, but I don't have the authority.  (I'm a bit unsure what registration buys me if it's not the ability to open a new bug.  I could read bugs without registering!).

Thanks for any help.

Offline

#2 2018-03-13 17:15:34

andreas_baumann
Moderator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 294
Website

Re: Bug report: LXDM fails with invalid op-code in librsvg-2:2.42.1-1.0

Mmh. lxdm-greeter-gt is in which package? I have a LXDM running on a virtual immage with Pentium II CPU and it starts..

Offline

#3 2018-03-13 21:18:26

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 209

Re: Bug report: LXDM fails with invalid op-code in librsvg-2:2.42.1-1.0

goverp: I just promoted your status on the bugtracker to "reporter". Sry about the inconvenience, but we really would like to keep the spam (which we now have in the forum) out of the bug tracker smile

Offline

#4 2018-03-23 12:14:27

andreas_baumann
Moderator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 294
Website

Re: Bug report: LXDM fails with invalid op-code in librsvg-2:2.42.1-1.0

librsvg without SSE2 and qt5-declarative without SSE2 have been pushed to stable,
can you give it another try?

Offline

#5 2018-03-26 11:00:26

goverp
Member
Registered: 2018-03-03
Posts: 3

Re: Bug report: LXDM fails with invalid op-code in librsvg-2:2.42.1-1.0

Thanks for sorting my bugtracker access out.

I updated my system a couple of days ago, and find that it's consistently fixed my problem;
that's librsvg 2:2.42.3-1.2
So thanks for fixing that.  (I don't know if qt-declarative was involved, as LXDM was stopping me getting to a desktop.)

Offline

Board footer

Powered by FluxBB